تعارف عربي مصري


تعارف عربي مصري



 
الرئيسيةالرئيسية  الصفحه الرئيسيهالصفحه الرئيسيه  اليوميةاليومية  مكتبة الصورمكتبة الصور  س .و .جس .و .ج  بحـثبحـث  التسجيلالتسجيل  دخولدخول  

شاطر | 
 

  طريقه تجعل الميكروتيك mikrotik يكتشف المواقع الاباحية ويقفلها لوحدة

اذهب الى الأسفل 
كاتب الموضوعرسالة
اكرامي الفيومي
مدير الموقع
avatar

عدد المساهمات : 564
نقاط : 1514
تاريخ التسجيل : 08/04/2010
العمر : 36

مُساهمةموضوع: طريقه تجعل الميكروتيك mikrotik يكتشف المواقع الاباحية ويقفلها لوحدة    الجمعة 16 يوليو 2010 - 13:39

[ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذه الصورة] طريقه تجعل الميكروتيك mikrotik يكتشف المواقع الاباحية ويقفلها لوحدة



السلام عليكم ورحمة الله وبركاته

بسم الله والصلاة والسلام على رسول الله صلى الله عليه وسلم

لقد كتبت قبل ذلك موضوع انك تخلى الميكروتيك يدتكت النت كت ويقفل عليه اوتماتيك

وباذن الله اليوم سوف نتعلم سويا طريقه تخلى الميكروتيك يقفل المواقع الاباحية لوحدة اوتماتيك باذن الله ولكن قبل ان اشرح صلى على نور الهدى

بسم الله

اولا الفكرة انا لقتها فى الويكى بتاع الميكروتيك بس كانو عملنها بالفيروال فاخدتها وعدلتها حتى تنفع معا الويب بروكسى فهو ارحم من الفيروال

الفكر ان الميكروتيك يبحث فى الموقع التى يفتحها الناس ثم ان وجد كلمة مثلا زى sex مثلا هياخد الموقع بالكامل ويقفله وده عن طريق اسكربت هيشتغل كل 15 دقائق مثلا

خد الى هحطة وحطه فى الترمنال من غير متعدل فى اى حاجه وهو مجرب على الاصدار 3.13

صلى على سيدنا محمد قبل ان تاخد الاسكربت

طريقة وضع السكربت هى ip-----system--------script

ثم ضع اسم السكربت فى خانة name وليكن block ثم ضع ما يلى فى خانة source

خلي اسم السكربت block علشان لاننا سوف نحتاجه

كود PHP:

:foreach i in=[/ip dns cache find] do={
:
local bNew "true";
:
local cacheName [/ip dns cache all get $i name] ;
# :put $cacheName;
:if (([:find $cacheName "adult"] != 0) || ([:find $cacheName "sex"] != 0)) do={
:
local tmpName [/ip dns cache get $i name] ;
# :put $tmpName ;
# if address list is empty do not check
:foreach j in=[/ip proxy access find ] do={
:if ( [/
ip proxy access get $j dst-host] = $tmpName ) do={
:
set bNew "false";
}
}
:if (
$bNew = "true" ) do={

/
ip proxy access add disabled=no comment=$cacheName dst-host=$tmpName action=deny ;
}
}
}


ولو حبيت تغير اسم الموقعين الى انا خليتو يدور عليهم ويقفلهم غير كلمت sex و كلمت adult

وبعدين افتح new termnla واكتب فيها مايالى

كود PHP:
/system scheduler add name=block on-event="block" interval=00:15:00 comment=block-xx-web



منقول للفائدة

_________________
[ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذه الصورة]

[ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذه الصورة]

[ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذه الصورة]

[ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذه الصورة]
الرجوع الى أعلى الصفحة اذهب الى الأسفل
 
طريقه تجعل الميكروتيك mikrotik يكتشف المواقع الاباحية ويقفلها لوحدة
الرجوع الى أعلى الصفحة 
صفحة 1 من اصل 1

صلاحيات هذا المنتدى:لاتستطيع الرد على المواضيع في هذا المنتدى
تعارف عربي مصري :: منتدي البرامج العام :: الشيكات :: منتدي المايكروتك-
انتقل الى: